7-13 是否完全二叉搜索树 (30 分)

发布时间:2019年03月30日 阅读:283 次

7-13 是否完全二叉搜索树 (30 分)

将一系列给定数字顺序插入一个初始为空的二叉搜索树(定义为左子树键值大,右子树键值小),你需要判断最后的树是否一棵完全二叉树,并且给出其层序遍历的结果。

输入格式:

输入第一行给出一个不超过20的正整数N;第二行给出N个互不相同的正整数,其间以空格分隔。

输出格式:

将输入的N个正整数顺序插入一个初始为空的二叉搜索树。在第一行中输出结果树的层序遍历结果,数字间以1个空格分隔,行的首尾不得有多余空格。第二行输出YES,如果该树是完全二叉树;否则输出NO

输入样例1:

9
38 45 42 24 58 30 67 12 51

输出样例1:

38 45 24 58 42 30 12 67 51
YES

输入样例2:

8
38 24 12 45 58 67 42 51

输出样例2:

38 45 24 58 42 12 67 51
NO
#include<bits/stdc++.h>
using namespace std;
int a[20000];
void Insert(int root,int i){
  if(a[root]==-1){

    a[root] = i;
    return ;
  }
  if(i>a[root]){

    Insert(root*2,i);
  }
  else Insert(root*2+1,i);

}
int  top;
void cc(){
   queue<int>o;
   o.push(1);
   top = 1;
   while(!o.empty()){

      int p = o.front();
      o.pop();
      if(top) top = 0;
      else printf(" ");
      printf("%d",a[p]);
      if(a[p*2]!=-1)o.push(p*2);
      if(a[p*2+1]!=-1)o.push(p*2+1);
   }

}
int main()
{
    memset(a,-1,sizeof a);
    int n;
    cin>>n;
    for(int i=0;i<n;i++){

        int num;
        cin>>num;
        Insert(1,num);
    }

    cc();
    printf("\n");
    for(int i=1;i<=n;i++){

        if(a[i]==-1){
            printf("NO\n");
            return 0;
        }
    }
    printf("YES\n");


    return 0;
}


Tag:
相关文章

发表评论: