7-14 周游世界 (30 分)

发布时间:2019年03月23日 阅读:432 次

7-14 周游世界 (30 分)

周游世界是件浪漫事,但规划旅行路线就不一定了…… 全世界有成千上万条航线、铁路线、大巴线,令人眼花缭乱。所以旅行社会选择部分运输公司组成联盟,每家公司提供一条线路,然后帮助客户规划由联盟内企业支持的旅行路线。本题就要求你帮旅行社实现一个自动规划路线的程序,使得对任何给定的起点和终点,可以找出最顺畅的路线。所谓“最顺畅”,首先是指中途经停站最少;如果经停站一样多,则取需要换乘线路次数最少的路线。

输入格式:

输入在第一行给出一个正整数),即联盟公司的数量。接下来有行,第行()描述了第家公司所提供的线路。格式为:

 S[1] S[2]  S[]

其中)是经停站的数量,S[]()是经停站的编号(由4位0-9的数字组成)。这里假设每条线路都是简单的一条可以双向运行的链路,并且输入保证是按照正确的经停顺序给出的 —— 也就是说,任意一对相邻的S[]和S[]()之间都不存在其他经停站点。我们称相邻站点之间的线路为一个运营区间,每个运营区间只承包给一家公司。环线是有可能存在的,但不会不经停任何中间站点就从出发地回到出发地。当然,不同公司的线路是可能在某些站点有交叉的,这些站点就是客户的换乘点,我们假设任意换乘点涉及的不同公司的线路都不超过5条。

在描述了联盟线路之后,题目将给出一个正整数),随后行,每行给出一位客户的需求,即始发地的编号和目的地的编号,中间以一空格分隔。

输出格式:

处理每一位客户的需求。如果没有现成的线路可以使其到达目的地,就在一行中输出“Sorry, no line is available.”;如果目的地可达,则首先在一行中输出最顺畅路线的经停站数量(始发地和目的地不包括在内),然后按下列格式给出旅行路线:

Go by the line of company #X1 from S1 to S2.
Go by the line of company #X2 from S2 to S3.
......

其中Xi是线路承包公司的编号,Si是经停站的编号。但必须只输出始发地、换乘点和目的地,不能输出中间的经停站。题目保证满足要求的路线是唯一的。

输入样例:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
4
3011 3013
6666 2001
2004 3001
2222 6666

输出样例:

2
Go by the line of company #3 from 3011 to 3013.
10
Go by the line of company #4 from 6666 to 1306.
Go by the line of company #3 from 1306 to 2302.
Go by the line of company #2 from 2302 to 2001.
6
Go by the line of company #2 from 2004 to 1204.
Go by the line of company #1 from 1204 to 1306.
Go by the line of company #3 from 1306 to 3001.
Sorry, no line is available.
#include<bits/stdc++.h>
using namespace std;
struct node
{
    int station,line,ji_sta,ji_line;
    node() {}
    node(int a,int b,int c,int d):station(a),line(b),ji_sta(c),ji_line(d) {}
    bool operator<(const node&tt)const
    {
        if(tt.ji_sta!=ji_sta)
        {
            return ji_sta>tt.ji_sta;
        }
        return ji_line>tt.ji_line;
    }
} now;
struct line
{
    int u,v,w,next;
} edge[10010];
int head[234234];
int cnt;
void add(int u,int v,int w)
{

    edge[cnt].u = u;
    edge[cnt].v = v;
    edge[cnt].w = w;
    edge[cnt].next = head[u];
    head[u] = cnt++;

    edge[cnt].u = v;
    edge[cnt].v = u;
    edge[cnt].w = w;
    edge[cnt].next = head[v];
    head[v] = cnt++;


}
int l,s;
priority_queue<node>o;
int line[300][10300],station[300][10300];

int bfs(int S,int E)
{

   int vis[435];
    memset(vis,-1,sizeof vis);
    while(!o.empty())o.pop();
    o.push(node(S,-2,0,0));
    while(!o.empty())
    {

        now  = o.top();
        o.pop();
        if(now.station==E)
        {

            l = now.line;
            s = now.station;
            return now.ji_sta;
        }
        int u = now.station;
        for(int i=head[u]; ~i; i=edge[i].next)
        {

            s = edge[i].v;
            l = edge[i].w;
            if(line[s][l]==-1)
            {

                line[s][l] = now.line;
                station[s][l] = now.station;
                int k;
                if(l!=now.line)k = now.ji_line+1;
                else k = now.ji_line;
                o.push(node(s,l,now.ji_sta+1,k));

            }
        }
    }
    return -1;

}
int ans_l[10300],ans_s[10300],ans_e[10323];
int main()
{

    int n;
    cin>>n;
    cnt =0;
    memset(head,-1,sizeof head);
    memset(station,-1,sizeof station);
    memset(line,-1,sizeof station);
    for(int i=1; i<=n; i++)
    {

        int p,pre ;
        cin>>p>>pre;
        for(int j=1; j<=p-1; j++)
        {
            int num;
            cin>>num;
            add(pre,num,i);
            pre = num;
        }

    }
    int m;
    cin>>m;
    for(int ii=1; ii<=m; ii++)
    {

        int S,E,ll,ss;
        cin>>S>>E;
        int ans_cnt = bfs(S,E);
        if(ans_cnt != -1)
        {
            printf("%d\n", ans_cnt);
            if(ans_cnt == 0)
            {
                printf("Go by the line of company #%d from %04d to %04d.\n", edge[head[S]].w,S, E);
                continue;
            }
            ans_l[0] = -1;
           int  ans_num = 1;
            while(s != S)
            {
                ans_l[ans_num] = l;
                ans_s[ans_num] = station[l][s];
                ans_e[ans_num++] = s;

                ll = l;
                l = line[l][s];
                s = station[ll][s];
            }
            ss = S;
            for(int i = ans_num - 1; i > 0; --i)
            {
                if(ans_l[i] != ans_l[i - 1])
                {
                    printf("Go by the line of company #%d from %04d to %04d.\n", ans_l[i], ss, ans_e[i]);
                    ss = ans_s[i - 1];
                }
            }
        }
        else
        {
            printf("Sorry, no line is available.\n");
        }
    }


return 0;
}


Tag:
相关文章

发表评论: